Kayıt Ol

Giriş

Şifremi Kaybettim

Şifreni mi unuttun? Lütfen e-mail adresinizi giriniz. Bir bağlantı alacaksınız ve e-posta yoluyla yeni bir şifre oluşturacaksınız.

Giriş

Kayıt Ol

TLS Verification Failed. TLS version is not compatible – Paypal – Çözümü

Zaman su gibi akıp geçerken teknoloji de hızla gelişiyor, versiyonlar ardı arkası kesilmeksizin yenileri çıkıyor. TLS/SSL’in de belirli aralıklarla yeni versiyonları çıkıyor ve şirketler (örn: Paypal) yeni versiyonları zorunlu kılıyor.

TLS Versiyonları:

  • TLS 1.0 – 1999’da yayımlandı, ayrıca TLS’in bu versiyonu SSL’in 3.0 versiyonuna oldukça benzer. (RFC 2246)
  • TLS 1.1 – 2006’da yayımlandı (RFC 4346).
  • TLS 1.2 – 2008’de yayımlandı (RFC 5246). Günümüzde Paypal’ın zorunlu kıldığı versiyondur. 
  • TLS 1.3 – Ocak – 2016’da yayımlandı. (RFC 4346)

For EN, go to end of the page.

Paypal tarafı: https://www.paypal.com/au/webapps/mpp/tls-http-upgrade

TLS Verification Failed. TLS version is not compatible için Paypal der ki:

Sistemlerimizle yapılan tüm dış bağlantıları korumak için kullanılan protokolleri yükseltiyoruz. Aktarım Katmanı Güvenliği sürüm 1.2 (TLS 1.2) ve Köprü Metni Aktarım Protokolü sürüm 1.1 (HTTP / 1.1), PayPal ile iletişim kurmak için 2018’de zorunlu hale gelmiştir.

Ortamınızın TLS 1.2 ve HTTP / 1.1’i desteklediğini doğrulamanız ve gerekirse uygun güncellemeleri yapmanız gerekir.

Dolayısı ile HTTP versiyonu minimum 1.1 ve TLS versiyonu ise minimum 1.3 olmalıdır. Eğer teknik bilgiye sahip birisi değilseniz bu durum için teknik destek aldığınız kişi/kurum ile iletişim kurmanız gerekir.

Bu çalışmayı sunucu kontrol paneliniz üzerinden oldukça pratik bir şekilde yapabilirsiniz. Sunucu kontrol paneliniz yoksa ilgili derleyicinizin config dosyası üzerinden bu güncellemeyi yapabilirsiniz.

Hata: TLS Verification Failed. TLS version is not compatible.

Nedeni: TLS versiyonun eski olmasıdır.

Çözüm: İlgili derleyici üzerinden konfügirasyon ayarlarını yapmak.

Bu örneğimizi Plesk – sunucu kontrol paneli üzerinden yapacağız.

TLS Verification Failed. TLS version is not compatible - Paypal - Çözümü

Görseldeki gibi, ilgili domainin detay sayfası üzerinden Apache & Nginx Settings sayfasına geçiryoruz.

Plesk - TLS Verification Failed. TLS version is not compatible - Paypal - Çözümü

Additional nginx directives alanına:

ssl_protocols TLSv1 TLSv1.1 TLSv1.2;

yazıp, kaydediyoruz. Evet, hepsi bu kadar!

— ENGLISH 

Error: TLS Verification Failed. TLS version is not compatible.

Reason: Outdated TLS version (for Paypal).

Solution: Upgrade TLS version.

 

You have to upgrade your TLS version of compiler. 

  • Open your server panel (Plesk),
  • Go to domain detail page,
  • Find and click the Apache & Nginx Settings,
  • Paste:
    # ssl_protocols TLSv1 TLSv1.1 TLSv1.2;

  • and Save it.
  • That’s it.

If you don’t have a server control panel, you can do this on your compiler’s config settings.

 

Hakkında Adıgüzel Boz

Cevap bırakın

Güvenlik Kodu Captcha güncellemek için resime tıkla